Skieblu’s 3.0 Bug Hunt (updated February 26th)

This was formerly titled the 2.12 bug hunt thread. Since a lot of bugs carried over from 2.12 to 3.0 and not a lot of new ones were made, I found it simpler to just edit this thread. All bug issues that were fixed in 3.0 and the hotfixes up to 3.0.2 have been removed, but you can view the in the edit history.

Due to the UI changes, all of the UI related bugs from 2.11 are now non-existent. They also fixed the crucial Varya bug in a patch between 2.11 and 2.12. As for the turret lasers, they seem to be in place. The main bug that seems to be still apparent is when you tap the mini map, you will still sometimes go to that location. However, you can work around this by setting your camera to free cam and tap on the mini map freely without going to the location. Another bug that is sticking around is that varya still channels her spear even when she dies while doing it.

Here are the ones other people have reported:
Blitz scores of your teammates are not shown on the scoreboard anymore.

Left handed mode is missing/non-existent

@RSerperior found this bug with fortress where his wolves will also give him a speed boost with his perk even though they are not allied heroes

Edit: apparently this was intentional, but I’ll keep it here just in case

@IncinerateZ discovered that buying a minion’s foot while dead will not give you the passive which garuntees a crit on the first basic attack on an enemy hero.

The following are bugs I have found. Some of these I have posted on Reddit, but I’m not sure if the right people have seen them:
You can zoom in and out for regular cards, but if you try to zoom out a talent coin by tapping outside of the window, it closes the entire quest window. If you click the small x, this will not occur, but it is quite annoying to try to tap it.

The text is not always displayed correctly with the smaller windows

On the topic of messed up text, the spoils of war can be glitchy too.

this one happened right after I leveled up.

If you open up the skin section in the market, it will initially not show which skins/blueprints you have. You can fix this by clicking one of the skins.

The supporter badge does not properly display on the 5v5 versus screen.

There are times where after you complete a match, the guild chat disappears.

NEW: The change skin button that appears after selecting a hero in other matches is not shown in battle royale, you have to select your intended role/build to be able to change your skin.

NEW: In matches that tell you to play in any game mode except ranked or practice, you can still complete your quest by playing a PvP blitz match even though it is titled ranked. For this, I would just rename ranked blitz to something else or actually make a casual version of blitz.

The bush that is to the left of the top river shop aka the bush that is to the right of the bottom river shop is rendered improperly, having a random spike jutting out of it.

The expected wait time timer does not show actual times, it just shows the time you have in queue and <1 minute if you have been in queue for less than a minute.

SAW’s spin up stacks do not display the same numbers when your spin up stacks are winding down. As in, when you are winding down in spin up stacks, the indicator in the bottom left corner will say you have no stacks while the indicator below your health and energy will say you have 3 or 4 stacks.

When you are in the base, you get this gold pot icon shown. This was never seen in previous updates, and it does not seem to show anything aside from the fact that you are in the base. If this is intentional, then they should use another icon instead of a gold pot because it is misleading since it looks like you’re getting bonus gold income.

inside the base outside the base
EDIT: I have figured out that the gold pot icon actually is a notification that you are able to shop, this also shows up in the jungle shop and river shop. This is nice and all, but it is rather redundant because you can tell if you can shop by the shop button glowing a little with radiating circles.

When you select a low tiered/default skin and then tap on the change skin button, the highest tiered skin you own will be automatically selected, which is rather annoying for people who prefer a lower tiered skin over a higher tiered one.

You cannot thumbs up/down heroes after you lock a hero in. Additionally, you can press the thumbs up/down button after selecting a hero and it will just give you a thumbs up/down on the hero you selected, which can be annoying.

You can now select roles in blitz, but it does not display the role you selected.

Although the new scoreboard shows that your ally is afk, it now shows which enemies are afk before the match ends. This is detrimental because the other team can use that information to know where to focus their attention on.

On the topic of AFK allies, if the dropdown section of thumbs down for a player goes off the screen for the bottom heroes, which I assume is mainly just a problem for mobile devices.

Fog of War does not cover the dragon locations, so you can see the enemy ability effects if they are taking one of them. I do not know if this was fixed yet.

You can sell your items that give you bonus scout cams and repurchase them to get even more scout cams. This can result to having an absurd amount of scout cams if you have enough gold.

Allied scout traps and flares don’t show up on the mini map in 3v3 even though the camps that are near it will be revealed. This is very detrimental especially for the captain to know what areas they have secured with vision.

If I find any other bugs, I’ll post them here.


Bookmarked. Awesome what you’re doing.

Some extra stuff:

  1. Can’t surrender in 5 v 5 even after teammates have abandoned. I’m talking like 2-3 players abandoning.
  2. Also, I’m not sure if it’s an Android thing, but we can’t use the back button to exit the game. Only the home button works.
  3. Not being able to see the range of options when deciding to thumbs down the last guy on the list for 5 v 5. E.g., only ‘AFK’ and ‘Trolling’ can be seen, the rest go off the page.

Sorry for not having any screenshots as evidence.

Anyways, it’s good to see you here man :slight_smile:

I just had a bug where I was locked in place. This wasn’t lag. I could move about 2 meters each direct before I would be pulled back in place. I could recall and I would travel back to the same spot. I have video but I suck at that stuff.

1 Like

This was suppose to be fixed in the update today. Are you using ios or Android? Have you updated your vainglory app today?

I always loved these! haha! They were always so useful. But they are still great for anyone to go through!


It does seem intentional imo. To be able to see ability effects, so one can make a decision to contest it or not. It is quite subtle and the number of heroes around the dragons are still hidden, making it a risky venture.

Updated iOS yesterday. V 2.12.1. I am not seeing a new update.

They fixed it in 2.12.2 it may not have hit ios yet.

1 Like

@Skieblu The number may be from the talents section of the market, if you open the talents section and close it, the number may go away. There will be a number on the market icon relating to the talents section if you already have the talent coin and the coin is also available for purchase on that day.

1 Like

u know that I did one of these before you started but it was more of flaming semc for a buggy mess.

Sometimes typing in guild chat, my messages disappear and reappear

Not a bug, but after 2.12.2, I repeatedly hit 20,000 ms. Usually average 100-150.

That worked, thanks.

Though they do need to be more clear where the deal is, I wouldn’t have known of it if you didn’t tell me.

I’ve been continuously updating this thread as I find new bugs, and I guess I’ve added enough that it warrants a bump.

I’m not too sure if this was mentioned yet. Some times your hero walks in one direction only without pressing anything.

I’m having the same bug :pouting_cat::thinking::thinking::thinking::thinking::thinking::thinking::thinking::thinking::thinking::thinking::thinking::thinking::thinking::thinking:

The fix for this is to press with two or three fingers somewhere else on the screen.

Some bugs have been resolved in the 2.12.2 patch, though I did figure out the purpose of the golden pot and discovered the exploit of exceeding the maximum number of scout cams.

1 Like

What’s the purpose of the golden pot??? Never knew the purpose.